Skip to content. | Skip to navigation

Navigation

Personal tools
You are here: Home / Community / News And Announcements / Older Apple Devices Can Not Log In: SOLVED

Older Apple Devices Can Not Log In: SOLVED

Some Apple users were reporting that the site is being labelled 'unsafe' by Safari and Chrome browsers and the log in form is not being displayed.

[Update Saturday Oct 9]

About midday today the problem was solved. There is nothing you should need to do.

We are currently gathering confirmations from all of the affected members who contacted us.

IF YOU ARE STILL UNABLE TO LOG IN PLEASE CONTACT US IMMEDIATELY (or send an email to 'support' at this domain name)

Our huge thanks to Aaron B., a Trusted Advisor who helped us test several days of attempted fixes.

~ Ian F. Hood, CTO

 


[Updated Friday Oct 8]

Apple's emergency security updates (Sep 13th, 2021) may be involved, but not if you got the update.  If you didn’t get an update, your device may be at serious risk to a zero-click vulnerability that is now widely known. This is beyond the scope of our investigation, but you can find out more here.

An outdated, but critical link in the verification 'keychain' for more than 2 billion Trust Certificates expired officially on September 30th, 2021. This certificate expiry had already been postponed by a year because of Apple update issues.

These are the certificates that browsers use to determine whether a website is safe to use, or not.  When in doubt, the browsers may take action, such as blocking the use of forms to protect your sensitive information (passwords, credit cards, etc).

Updated devices would have handled this change without skipping a beat, but devices that are not getting updates directly from Apple will have failed to make this transition automatically.

Click here for a thorough explanation.

Though the problem is between Apple and the Certification service, we are looking at ways to overcome the problem, such as purchasing all new certificates with a different provider and reconfiguring our servers.  This shouldn't be necessary, but we'll be ready to take action if this isn't resolved by Monday.


[Update Thursday Oct 7]  The following workaround has not yet been confirmed by anyone that we know personally... it's possible that browser caches must be cleared and the device rebooted, but we are still attempting to confirm this. We are also making adjustments to our servers that we hope will help.  If you try this please let us know if it solves your problem or not.

Here are the instructions for manually updating your mac or iOS device:

  1. Try a restart of the affected device.  In some cases the update has been downloaded but not activated.
  2. If restart does not work:
    1. Download the ISRG Root X1 certificate file from http://x1.i.lencr.org/
    2. Open the 'Keychain Access' app and drag that file into the System folder of the app
    3. Find the ISRG Root X1 certificate in the System folder and double click on it
      1. open the Trust menu and change "Use System Defaults" to "Always Trust"
      2. then close that and enter your password to confirm the change (if prompted)

Copy This Link for an external, public copy of these instructions that you can share with others.

Please Contact Us (here) or email support at trustedadvisortoolkit.com if you are in urgent need .. we'll do our best to assist you.

Thank you for your patience.

~ Ian F. Hood, CTO and The Toolkit Team